Beiträge von Matthias

    Hallo im Forum,

    dank an alle, die sich um mich bemüht haben!

    So hat's nun endlich geklappt:


    wlan_ssid = "FRITZ!Box 7430 IW"

    wlan_passwort = "00000000000000000000"

    Einfach Nullen, so wie ich :D

    Mit USB trennen, war ein guter Tip. Hatte die Box auch mal neu gestartet.

    In der Benutzeroberfläche stehen auch diese Korrekten Formate der Eingabe drin, so wie hier angegeben.


    Gruß

    Matthias

    ich habe über die geladenen Programme keinen Zugang ins Internet.

    Meine Zugangsdaten gebe ich wie folgt ein:


    wlan_ssid = "7430 IW"

    wlan_passwort = "0000-0000-0000-0000-0000" (natürlich mit dem richtigen Schlüssel)


    Keine Verbindung zum WLAN


    Was könnte die Ursache sein?


    Gruß

    Matthias

    Hallo René,

    danke für deine wie immer schnelle Antwort. Ich habe diese Akkus hier( https://www.akkushop.de/de/sam…r-ohne-loetfahnen/?c=2775). Ich hab mir jetzt mit einem Provisorium geholfen, da ich ja nicht so offt laden muss.

    Die Ladeschlussspannung für einen Akku ist wohl hier 4,1V. Beim Ladestrom bin ich mir nicht sicher. Nimmt man hier ein Zehntel der Kapazität oder mehr? Der Strom klettert hier auf über 1A. Ich hab ihn auf 350mA runtergeregelt.


    Gruss

    Matthias

    Hallo im Forum,


    wie ladet ihr die Akkus vom Roboter?

    Ich habe so ein Labornetzteil, dass hatte René in einem Video vorgestellt, da is der Strom einstellbar.

    Is das möglich über das USB Kabel zu laden oder schadet das der Platine? Da muss ja eine Verbindung zum Akku sein. Oder besser über eine Verbindung direkt zur Batteriehalterung?



    Gruss

    Matthias

    Hallo René,

    danke für deine ausführliche Beantwortung. Mit dem Sketch kann man super hinter die Kulissen schauen und im Detail nachvollziehen, was da passiert. Mir war es ein Rätsel, woher der aktuelle Winkel die Null zugewiesen bekommt. Die Implementierung von augen.init() ist mir dabei ganz entgangen. Da fiel doch gleich der Schuppen von den Augen^^!

    Ich wünsch dir kühlen Kopf bei den Temperaturen.


    Gruss

    Matthias

    Hallo, an alle Freunde des wolkenlosen Himmels :cursing:!

    Die Ansteurung des Servo ist mir schon einigermassen klar, nur wenn ich mir den Sketch im Deteil anschaue, gehen da so einige Türen wieder zu.

    Im Hauptprogramm gibts da eine, mir bis dahin neue if - Abfrage mit der Funktion if (augen.langsam(ziel,schritt)). Ich deute das so, dass die Funktion aktiv is,t sobald die Parameter in Klammern vorhanden sind, ausser schritt = 0. Wenn das Ziel erreicht ist wird true zurückgegeben und die Klammer wird ausgeführt, also das Ziel wird dann positiv (+90) und das Spiel beginnt von vorn. Meine Frage, der typ boolean kennt doch nur false und true aber in der Funktion boolean Augen :: langsam(int winkel, int schritt) wird return (zielWinkel == aktuellerWinkel) zurückgegeben und wohin?

    Wie gross ist der aktuelleWinkel beim ersten Durchlaufen der Funktion? Der könnte ja nur 0 sein, aber hat ja theoretisch noch keinen Wert, erst wenn die Funktion int Augen :: setRichtung (int winkel) aufgerufen wird bekommt sie den Wert des übergebenen Winkels.

    Vielleich kann das Szenerio an hand von Zahlen mal durchspielt werden wenn mal Zeit ist !


    Gruss

    Matthias





    ,

    Hallo,

    danke euch für den Hinweis. Ich habe den Zusammenbau nur nach den Bildern getätigt, da muss ich was übersehen haben. Zum Glück habe ich mich

    mit meinen Äusserungen zurückgehalten :D! Die Schraube fehlte.


    Gruss

    Matthias

    Hallo im Forum,

    ich habe den Robot V2.0, der verliert ständig seine Augen beim herumschauen. Der Servo ist nur aufgesteckt und dadurch sehr insztabil. Was macht man da, einkleben oder hat jemand eine bessere Lösung? Zum Bausatz is da noch so ein Plastikteil, aber ich habe keinen Plan wozu das sein soll.


    Gruss

    Matthias

    Hallo René,

    ich entpacke die zip Dateien bis zum sketch, dann markiere ich alle .h, .cpp und ino Dateien und beim Öffnen kommt die Abfrage, mit welchem Programm ich nun die .h und dann die .cpp Dateien öffnen möchte. In der Vorgabe befindet sich aber keine Arduino App, Ich klicke dann so lange weiter bis alle Dateien abgefragt sind, erst dann öffnet sich Arduino.


    Gruss

    Matthias

    Hallo René,

    is ein bischen verwirrend, da nach meinem bisherigen Verständnis eine Schleife aktiviert wird, sobald eine vorgegebene Bedingung erfüllt sein musste. while (digitalRead(tasterPin) == LOW) { }; die Schleife befindet sich solange mit HIGH in der Warteposition, bis die Bedingung LOW durch den Tasterdruck erfüllt ist. Im Sketch wartet sie auf Änderung des Istzustandes HIGH!

    Ich werde es in Ruhe auseinanderpflücken und dann sehe ich vielleicht etwas besser durch. Wenn sich neue Gräben auftuen melde ich mich.

    Danke für deine Antwort.


    Gruss

    Matthias

    Hallo René,

    Warum muss ich eine While Schleife im set up bemühen, Bedingung gibts da auch keine. Die einfache Abfrage nur mit digitalRead bringt die Schleife aber sofort zum laufen.

    Was macht die start() Funktion schon im setup.


    Gruss

    Matthias

    Theorie ist auf die Dauer langweilig. Man möchte doch auch seine bescheidenen Kenntnisse in der Praxis realisiert sehen. Bevor ich mir eine Projekt schön rede und damit einen immensen Aufwand betreiben muss, finde ich so einen Dummy ganz praktisch.